Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 13 von 13
  1. #11
    Dreamer Avatar von ax999
    Registriert seit
    Mar 2012
    Beiträge
    830
    Box(en):  DM900ultraHD  DM800se 
    koepi nicht arki

  2. #12
    VIP Avatar von Fred Bogus Trumper
    Registriert seit
    Feb 2008
    Beiträge
    988
    Box(en):  DM900ultraHD  DM7020HD  DM800se 
    lol , srry
    Gruß Fred

  3. #13
    VIP Avatar von Fred Bogus Trumper
    Registriert seit
    Feb 2008
    Beiträge
    988
    Box(en):  DM900ultraHD  DM7020HD  DM800se 
    Zitat Zitat von Dr.Best Beitrag anzeigen
    Wenn keine pyo erzeugt wird ist das meistens ein Anzeichen, dass es einen Fehler während der Kompilierung gab. Ein Enigma2-Log während des Startvorgangs würde da vermutlich weiterhelfen.


    Es werden nur Dateien kompiliert, wenn die Klassen darinnen auch tatsächlich irgendwo verwendet werden oder wenn diese von anderen Dateien referenziert wurden. Also einfach mal eine Python Datei da abzulegen bewirkt keine automatische Kompilierung.
    Du hattest (wieder mal ;-) ) recht

    die .pyo gelöscht und den Aufruf des Renderer in der skin.xml belassen und E2 neu gestartet. Die .pyo wurde kompiliert und die gewünschte Anzeige in der Infobar passt auch.

    Gestern war ich mir nahezu sicher, dass die .pyo im OE2.0 damals ohne Aufruf in der skin.xml kompiliert wurde. Also erst mal testen ob der code passt ohne einen Dauer-GS zu erhalten weil der Aufruf im skin knallt. Aber jetzt bin ich mir nicht mehr so sicher ...

    Jedenfalls wieder etwas dazu gelernt
    Gruß Fred

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •